Project

General

Profile

Support #68

SSL Problem - PUSH

Added by Jean-Manuel Da Silva over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Urgent
Category:
-
Target version:
-
Start date:
03/28/2009
Due date:
% Done:

100%

Estimated time:
Close

Description

Problème de PUSH avec hg.
J'ai bien pull mes modifs sur mon répertoire local.

Quand je push en faisant :
hg push -e ssh:/beem-xmpp

pushing to http://beem-project.com/hg/beem-xmpp
searching for changes
ssl required

J'ai matté la FAQ de hg et rajouter un push_ssl = false dans le hgrc de mon repo, mais rien n'y fait.

cat .hg/hgrc

[web]
push_ssl = false
[paths]
default = http://beem-project.com/hg/beem-xmpp

Si quelqu'un a une idée, la je cale.

PS : Hmm sinon comme on le voit j'ai pas mal de petits problême de conf à la con. Ce serait pas mal de remplir le wiki avec mes questions de noob. Ca laisserait des traces.

#1

Updated by Frédéric Barthéléry over 11 years ago

  • Status changed from New to Assigned

tu fais de la merde :)
l'option -e prend un parametre qui indique quel binaire ssh utiliser et dans ton cas tu lui dis d'utiliser l'url comme commande, il lui manque donc un argument qui est le depot dans lequel push. Vu que tu ne lui precise pas il essaie de push dans le default que tu as dans ton hgrc (a savoir http://beem-project.com/hg/beem-xmpp) ce qui n'est pas autorise.

donc a toi de lui preciser correctement le bon depot.
hg push ssh:/beem-xmpp

PS: l'option -e pourrait te servir dans le cas ou tu es derriere un proxy comme nous a ce moment la tu pourrait faire un
hg push -e 'tsocks ssh' ssh:/beem-xmpp

#2

Updated by Jean-Manuel Da Silva over 11 years ago

  • % Done changed from 0 to 100

Hmm forcemment ca marche mieux sans le -e.
kthx! :>

#3

Updated by Frédéric Barthéléry over 11 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF